navicat EDB xDB need pg_authid.rolcatupdate ?

PostgreSQL 9.5以前的版本,pg_authid有个字段rolcatupdate,用来标记用户是否有更新catalog的权限。 如果rolcatupdate=false,即使是超级用户也不能更新catalog。

解决方法:更新一下navicat版本吧

相关链接:https://yq.aliyun.com/articles/27080#

https://www.navicat.com.cn/download/navicat-for-postgresql

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注